Difference between revisions of "Latitude 2100"

From ThorstensHome
Jump to: navigation, search
(general problems)
 
(13 intermediate revisions by 2 users not shown)
Line 1: Line 1:
This is a wiki/blog about my adventures with my Latitude 2100 featuring a touchscreen and factory-preinstalled Linux.
+
This is a wiki/blog about my adventures with my Latitude 2100 featuring a touchscreen and factory-preinstalled Linux. It comes with an Atom processor 1.6GHz (1 processor/1 core/2 threads).
 +
 
 +
= Sizing =
 +
I can watch videos with this notebook/netbook but scrolling in a browser is too slow for me some times. Never had issues with the available space on harddisk (80G). RAM is enough for my usage (2G).
  
 
= Operating system =
 
= Operating system =
Line 21: Line 24:
 
My Latitude 2100 has an Intel WiFi 5100 and I have a LinkSys WAG160N DSL router with firmware V1.00.07. Instead of a version number as it should have according to http://www.linksysbycisco.com/DE/de/support/WAG160N/download, it has "annex B" written.
 
My Latitude 2100 has an Intel WiFi 5100 and I have a LinkSys WAG160N DSL router with firmware V1.00.07. Instead of a version number as it should have according to http://www.linksysbycisco.com/DE/de/support/WAG160N/download, it has "annex B" written.
  
== first attempt ==
+
== problems with the LinkSys WAG160N router ==
 +
 
 +
=== first attempt ===
 
I got wireless working once like this:
 
I got wireless working once like this:
 
# update Ubuntu to 9.04
 
# update Ubuntu to 9.04
Line 32: Line 37:
 
however, this stopped working, probably because of the kernel update I had to perform around 2009-07-31.
 
however, this stopped working, probably because of the kernel update I had to perform around 2009-07-31.
  
== second attempt ==
+
=== second attempt ===
 
Read  
 
Read  
 
* http://www.linksysbycisco.com/DE/de/supportgplcode?gplsku=#WAG160N
 
* http://www.linksysbycisco.com/DE/de/supportgplcode?gplsku=#WAG160N
Line 39: Line 44:
 
* disabled WMM support
 
* disabled WMM support
 
* worked
 
* worked
 +
 +
== general problems ==
 +
I think once I had to install the package ipw-firmware. Also see iwl: https://wiki.debian.org/iwlwifi
 +
 +
After following http://thinkwiki.de/Linux_Intel_Wifi_Link and typing Fn_F6 Scanning in yast2 lan worked with SUSE 12.1.
 +
 +
It did for sure not work after updating the firmware and before typing Fn_F6. The output then was:
 +
<pre>
 +
linux-wmem:~ # iwconfig
 +
lo        no wireless extensions.
 +
 +
eth0      no wireless extensions.
 +
 +
wlan0    IEEE 802.11abgn  ESSID:off/any 
 +
          Mode:Managed  Access Point: Not-Associated  Tx-Power=off 
 +
          Retry  long limit:7  RTS thr:off  Fragment thr:off
 +
          Encryption key:off
 +
          Power Management:off
 +
         
 +
linux-wmem:~ # iwlist wlan0 scanning
 +
wlan0    Interface doesn't support scanning : Network is down
 +
</pre>
 +
After I did this, SUSE 13.2 worked with no problems also.
  
 
= Sound =
 
= Sound =
Line 50: Line 78:
 
  dd if=/dev/dsp of=audio.raw; dd if=audio.raw of=/dev/dsp
 
  dd if=/dev/dsp of=audio.raw; dd if=audio.raw of=/dev/dsp
 
Note however that the stock Ubuntu alsa drivers do not work correctly regarding sound recording. To fix this, the factory installation contains a package named alsa-dkms.
 
Note however that the stock Ubuntu alsa drivers do not work correctly regarding sound recording. To fix this, the factory installation contains a package named alsa-dkms.
 +
 +
Directly after installing, sound recording is a bit quiet which is bad for e.g. skype. To change the volume, use gnome-volume-manager.
  
 
= BlueTooth =
 
= BlueTooth =
Line 61: Line 91:
 
* Quickly restore the factory delivery state of the system by choosing a special entry in grub
 
* Quickly restore the factory delivery state of the system by choosing a special entry in grub
 
* Some notebooks forget they should boot from USB once you disconnect the USB disk. This one does not.
 
* Some notebooks forget they should boot from USB once you disconnect the USB disk. This one does not.
 +
 +
= GeekBenchMark =
 +
http://browser.primatelabs.com/geekbench2/235408
  
 
= My contribution =
 
= My contribution =
 
I contributed a bug report that led to SUSE being able to record sound on this netbook: https://bugzilla.novell.com/show_bug.cgi?id=529467
 
I contributed a bug report that led to SUSE being able to record sound on this netbook: https://bugzilla.novell.com/show_bug.cgi?id=529467
 +
 +
= See also =
 +
* [[my computers]]

Latest revision as of 19:59, 4 January 2016

This is a wiki/blog about my adventures with my Latitude 2100 featuring a touchscreen and factory-preinstalled Linux. It comes with an Atom processor 1.6GHz (1 processor/1 core/2 threads).

Contents

Sizing

I can watch videos with this notebook/netbook but scrolling in a browser is too slow for me some times. Never had issues with the available space on harddisk (80G). RAM is enough for my usage (2G).

Operating system

Once I had Ubuntu 9.04 installed from a refactoring partition from another Latitude 2100, the following worked out of the box:

  • touchscreen
  • wireless
  • sound
  • bluetooth

software

  • ubuntu-netbook-remix
  • launchpad
  • dell team

TouchScreen

My Latitude 2100 has Ubuntu as its operating system. It is Ubuntu 8.10 and upgrading to Ubuntu 9.04 makes the touchscreen not work as intended. With Ubuntu 8.10 you can calibrate the touchscreen using the command

calibration

This is counter-productive with Ubuntu 9.04.

WireLess

My Latitude 2100 has an Intel WiFi 5100 and I have a LinkSys WAG160N DSL router with firmware V1.00.07. Instead of a version number as it should have according to http://www.linksysbycisco.com/DE/de/support/WAG160N/download, it has "annex B" written.

problems with the LinkSys WAG160N router

first attempt

I got wireless working once like this:

  1. update Ubuntu to 9.04
  2. read google, disabled WMM support because dmesg said "wireless event too big"
  3. disable wireless security on the router
  4. verify you can use wireless
  5. enable wireless security WPA-personal (not, as I had it before, wpa-personal2)
  6. verify you can use wireless
  7. re-enable WMM support

however, this stopped working, probably because of the kernel update I had to perform around 2009-07-31.

second attempt

Read

Downloaded .15 firmware from http://www.linksysbycisco.com/DE/de/support/WAG160N/download and installed it.

  • disabled WMM support
  • worked

general problems

I think once I had to install the package ipw-firmware. Also see iwl: https://wiki.debian.org/iwlwifi

After following http://thinkwiki.de/Linux_Intel_Wifi_Link and typing Fn_F6 Scanning in yast2 lan worked with SUSE 12.1.

It did for sure not work after updating the firmware and before typing Fn_F6. The output then was:

linux-wmem:~ # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
linux-wmem:~ # iwlist wlan0 scanning
wlan0     Interface doesn't support scanning : Network is down

After I did this, SUSE 13.2 worked with no problems also.

Sound

My Latitude 2100 has an Intel High-Definition Audio 82801G (ICH7 family). It can play sound and it can record sound as long as you plug a microphone in. In the BIOS the "microphone" is enabled. Regarding the internal microphone I am suffering the following issue: https://bugs.launchpad.net/gnome-media/+bug/290543

amixer -c 0 cset iface=MIXER,name="Capture Switch" on

With the factory installation of Ubuntu 9.04 the following stuff works without problems:

audacity
dd if=/dev/dsp of=audio.raw; dd if=audio.raw of=/dev/dsp

Note however that the stock Ubuntu alsa drivers do not work correctly regarding sound recording. To fix this, the factory installation contains a package named alsa-dkms.

Directly after installing, sound recording is a bit quiet which is bad for e.g. skype. To change the volume, use gnome-volume-manager.

BlueTooth

With the latest 8.10 kernel, the following commands work:

hwinfo --bluetooth
hcitool scan
bluetooth-applet

Features

  • Fight the memory effect of your battery: Press Fn_F2 and the system will not charge the battery if plugged in.
  • Quickly restore the factory delivery state of the system by choosing a special entry in grub
  • Some notebooks forget they should boot from USB once you disconnect the USB disk. This one does not.

GeekBenchMark

http://browser.primatelabs.com/geekbench2/235408

My contribution

I contributed a bug report that led to SUSE being able to record sound on this netbook: https://bugzilla.novell.com/show_bug.cgi?id=529467

See also